npm 安装出现 UNMET DEPENDENCY 的解决方案

作者: cayman 分类: 编程技术 发布时间: 2017-06-19 20:05

npm i
muzhicloud@0.2.2 E:\com\muzhicloud_make_web
+– UNMET PEER DEPENDENCY react@15.4.2
+– react-dnd@2.3.0
| +– disposables@1.0.1
| `– dnd-core@2.3.0
`– UNMET PEER DEPENDENCY react-dom@15.4.2

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.1
npm WARN react-soundplayer@0.3.6 requires a peer of react@^0.14.x but none was installed.
npm WARN react-soundplayer@0.3.6 requires a peer of react-dom@^0.14.x but none was installed.

 

出现这个的时候,不要重新安装,只是提示我们当前不是最新版本,可以升级到最新版

如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。 必填项已用*标注